Description:
This document is the first of two in describing the basics needed to know for designing Printed Circuit Boards (PCBs) with Altium Summer Designer 09. This document will describe the schematic entry, libraries, and component design aspects of designing PCBs.
Table of Contents

Schematic Entry ................................................................................................................. 4
  Creating a Project and Adding Files .................................................................................. 4
  Adding Parts to your Schematic ....................................................................................... 6
Component Design ............................................................................................................... 11
  Schematic Component Design ......................................................................................... 11
  PCB Foot Print Design ..................................................................................................... 14
  IPC Footprint Wizard ....................................................................................................... 15
  PCB Component Wizard .................................................................................................. 21
  Setting a Component’s Footprint ...................................................................................... 22
Creating a Design ................................................................................................................ 24
  Adding Parts .................................................................................................................... 24
  Connecting Parts ............................................................................................................. 26
  Schematic Sheet Symbols ............................................................................................... 27
Appendix ............................................................................................................................... 31
  A.1 Repeated Schematic Symbol Design .......................................................................... 31

Table of Figures

Figure 1: Creating a PCB Project ......................................................................................... 4
Figure 2: Adding a Schematic Sheet ................................................................................... 5
Figure 3: Project Window .................................................................................................... 6
Figure 4: Datasheet Diagram of LP3872 .......................................................................... 7
Figure 5: Adding Parts to your Schematic ......................................................................... 7
Figure 6: Adding a part to your schematic ........................................................................ 8
Figure 7: Library Menu ....................................................................................................... 8
Figure 8: Available Libraries Window ................................................................................ 9
Figure 9: Creating a Component ......................................................................................... 9
Figure 10: Blank Component with Pins ............................................................................. 11
Figure 11: Adding a Rectangle body (left) and the Final Design (Right) ......................... 11
Figure 12: Rectangle Properties ......................................................................................... 12
Figure 13: Editing Component Properties ......................................................................... 12
Figure 14: Editing Component Pin Assignments ................................................................. 14
Figure 15: Finished Schematic Part .................................................................................. 14
Figure 16: Package Dimensions ....................................................................................... 15
Figure 17: IPC Footprint Wizard ...................................................................................... 16
Figure 18: IPC Footprint Wizard Component Selection .......................................................... 16
Figure 19: Footprint Dimensions .......................................................................................... 17
Figure 20: More dimension Info ......................................................................................... 18
Figure 21: Solder Fillet Density ........................................................................................... 19
Figure 22: Footprint Name .................................................................................................... 19
Figure 23: Footprint Save Location ...................................................................................... 20
Figure 24: Final Footprint ..................................................................................................... 20
Figure 25: PCB Component Wizard .................................................................................... 21
Figure 26: Component Wizard Component Pattern .............................................................. 22
Figure 27: Finding a Footprint .............................................................................................. 23
Figure 28: Browsing for Footprints ...................................................................................... 23
Figure 29: PCB Model Window ............................................................................................ 24
Figure 30: Schematic of Power Module .............................................................................. 25
Figure 31: Changing Passive Component Footprint .............................................................. 25
Figure 32: Adding the 2012 Standard Footprint ................................................................. 26
Figure 33: Wired and Net list connections .......................................................................... 27
Figure 34: Power, Ground, Port, and Off Sheet Symbols .................................................... 27
Figure 35: Creating a Schematic Sheet Symbol ................................................................... 28
Figure 36: Selecting a Schematic Sheet .............................................................................. 29
Figure 37: Top Level Schematic with Sheet Symbol ............................................................. 30
Figure 38: Repeated Schematics ......................................................................................... 31
Figure 39: Project Options Menu ....................................................................................... 32
Figure 40: Un-routed Schematic Sheets ............................................................................. 33
Figure 41: Base Room for Copied Routing ........................................................................... 33
Figure 42: Copying Room Formats ..................................................................................... 34
Figure 43: Copied Room Layout Format ............................................................................. 34
Schematic Entry

Creating a Project and Adding Files

To start, open Altium Designer by click start->Programs->Altium Designer 09. We first must create a new project. To do this click file->New->Project->PCB Project (Figure 1).

The project will show up under the projects tab on the left side of the window. If it is not visible click view->workspace panels->projects. Right click the new project (currently named PCB_Project1.PrjPCB) and save it on your drive. Name the project something unique relating to your design.

Next we will add some schematic sheets. Right click your project and select Add new to project->Schematic (Figure 2). You can also see under that menu you can add PCB sheets, Schematic libraries, and PCB Libraries.
The schematic sheet you added will now be visible under your project name on the left side. Save this and give it a unique name just like you did to the project. However, it should have a name regarding the specific module or block you wish to design on this single schematic sheet. You can add as many schematic sheets to a project. It is a good design technique to do this because it simplifies each sub schematic or sub module of a design to limit the amount of components on a sheet to the minimum necessary for that component to work. Go ahead and add a PCB sheet, a PCB library and a schematic library to your project as well. Save everything with a unique name.

To add a schematic library, right click your project and select Add new to project -> Schematic Library. Typically, you want to have one library for all of your components or for a group of specific components. An example would be microprocessors. You could create your own library of many different models of microprocessors like the MSP430. Or you could create a library that contains all of your specific parts for current design into one library. You do this so that you can reuse libraries across projects and avoid recreating a schematic representation of that part.
To add a part see the section labeled Component design. Each schematic library component will need to add a PCB footprint to a PCB library.

To add a PCB library, right click your project and select Add new to project->PCB Library. Typically, you want to have one library for all of your footprints or for a group of specific prints just like schematic libraries. To see how to add a PCB footprint, see the Component Design section.

To add a PCB sheet, right click your project and select Add new to project->PCB. This document will contain your final PCB layout that you will send out to be built. This will be our last step in the design process and will be covered in a separate PCB design document.

All of these documents can now be seen in your project window on the left side of Altium, and it should look like the picture in Figure 3.

![Project Window](image)

**Figure 3: Project Window**

**Adding Parts to your Schematic Sheet**

Now that we have a schematic sheet to work with, we will create our own circuit. We are going to try to design a voltage regulator using the Texas Instruments LP3872. A link to this data sheet is listed below the link to this PDF on the capstone wiki. We will refer to this data sheet throughout the design. We will be creating a circuit that looks like that in Figure 4. But first we will have to figure out how to add parts to our design.
To add parts from the Altium provided Libraries, select your schematic sheet on the left side under the projects sheet, then either right click or select from the top toolbar, Place->Part... (Figure 5).

Once you have selected the parts menu, a window like that in Figure 6 will pop up. Click the ... on the right side of the menu to select a specific part from a larger parts list. A new window will pop up that looks like Figure 7. There are a few important items about this menu.
Figure 6: Adding a part to your schematic

Figure 7: Library Menu

- More Parts
- Component List
- Available Libraries
- Adding New Libraries
- Component Characteristics
- 3D PCB Footprint View
- Schematic Designator
The first to note is the drop down menu on the top. Here is a list of all the libraries you can select parts from. The two most important ones are the **Miscellaneous Parts** and **Miscellaneous Connectors**. In these two sections there are pre-made schematic designators for all of the typical passive electrical components like transistors, resistors, capacitors, headers, inductors and many more. In other words, these two menus are the only two that are not full of typical ICs (integrated Circuits). All of these components have preset component properties such as footprint, comment, and component. However, all of these items can be changed to be whatever you want it to be. This drop down will also list any libraries you created and added to the project such as the `Motor_parts_sch_lib.SchLib` that is listed in the picture.

On the left side of Figure 7 is the component list. Here is a list of all the components in the selected library. In the **Misc Headers** and **Misc Parts** libraries, there are many versions of headers or types of passive components. In a library you create, there will be a list of all of the components you created. Below that menu is the Component characteristics window. This shows the default items for your selected component such as the footprint. To the right are the PCB footprint model and the schematic designator picture. These two items are pictures of what the component will look like in the schematic or the on a PCB layout.

If you wish to add a library that is not listed in that menu, click the ... menu on the top left (Figure 8). This window will have all the libraries you have added to Altium. To find other libraries, click the Install... button and change directors to `c:\Program Files\Altium Designer Summer 09\Library`. This directory contains some typical parts from many different manufacturers such as Texas instruments. Figure 9 shows some of the Analog Devices libraries that are provided.
These premade manufacturer libraries are awesome if you have a popular or simple part because you might not need to create a component or footprint in your schematic and PCB libraries. For instance, Altium’s Analog library has many premade components and footprints for their popular ARM processors as seen in Figure 9. If you found a library you wish to get components from, just click open and it will add to your project.

However, sometimes Altium will not have the IC’s you wish to use in your design in their extended libraries, so you will need to make it. The next section will describe component design.

Now you can search through all of your libraries for specific components in the window depicted in Figure 7. Once you have found a part you wish to use, double click that part and select ok to add it to your schematic. Do not worry about changing the designator numbers for right now, but go ahead and add some different components for practice.
Component Design

Schematic Component Design
Often times the Altium libraries do not have components you want or, you are unsure they have the correct package dimensions. Therefore, we will need to create a custom Altium part. This consists of two phases, creating a schematic symbol, and creating a PCB footprint for that symbol. First we will create the Schematic component. Switch to your schematic library and click Tools->New Component. We will base this design off of the voltage regulator, LP3872. Adding a new component brings up the window seen in Figure 9. Fill in the box with a unique name describing the part.

![New Component Name](image)

**Figure 9: Creating a Component**

After naming the component you will have a blank sheet with cross hairs through the center. You can always change the name, remove the component or switch between different components by clicking Tools menu from the top toolbar.

First we will place some pins. We will need to place pins for every connection the part has. Please reference the data sheet’s symbolic representation of the part with pin labels included. Click Place->Pin to add pins. Place one pin to start and double click it. Change the number and designator to the number ‘1’. You can also change other characteristics of the pin like pin length (can make it as large or small as you want, 20-30 is a good size). Now as you add more pins, the pins will auto-increment off of this first pin. However, instead of adding every new pin, if you shift right-click and drag on the first pin you added, a new pin labeled 2 will appear. Do this process until you have enough pins to satisfy the component. Your final product should look like that of Figure 10. To rotate a pin, press spacebar.

![Blank Component with Pins](image)

**Figure 10: Blank Component with Pins**
You will notice that I placed the pins in a strange positioning; I chose this to match the symbol given in the data seen in Figure 4. How you arrange the pins in the component editor does not matter, it is just for convenience later for. Just be sure the floating number is on the opposite side you wish to connect, or on the component body. Next add a Polygon body by clicking Place->Rectangle. This is seen in Figure 9. There are other shapes you can do as well besides rectangles. Then you will need to make the numbers visible (seen also in Figure 10) by make the rectangle transparent. Right click the box and click properties. Select the box that says ‘Transparent’. This is seen in Figure 11.

Figure 11: Adding a Rectangle body (left) and the Final Design (Right)

Next we will change some of the component properties. Click Tools->Component Properties. A picture of this window is in Figure 13. Here we can edit the part to give proper names to the pins besides numbers, give it a designator, and also supply a footprint. Change the designator to be ‘U?’ so that we can number the component later. Change the Comment to the part name. Then Click the Edit Pins button in the bottom left corner of Figure 13.
A new window will pop up, that will allow you to adjust information about all of the pins. This can be seen in Figure 14. Go ahead and assign names to each of the pins under the Name category that correspond to the symbolic naming conventions on the data sheet. Do not change the designators (pin numbers), just the pin names. This is very important that this matches the exact specification on the data sheet for each pin. For example, pin 3 is the GND pin. Datasheets always provide an exact pin assignment with name designator. Figure 15 will show a finished project for pin assignments. Do not forget to save this otherwise Altium will not recognize that the component has been finished yet.

You will notice one of the names has backslashes in after each character. Those are in there to format the lettering to have bar over the top of the name on the symbol. This is seen in Figure 15.
Next we will create a footprint for this component. Usually at the end of a data sheet there will be a figure that has package dimensions for the part you are using. See Figure 16 for an example for our LP3872 part. Typically, there are many different footprints listed at the bottom of the datasheet, just be sure the part you are ordering matches the footprint you are designing. In our example, we needed the SOT-223 package.
Figure 16: Package Dimensions

IPC Footprint Wizard

Figure 16 describes all of the dimensions we need in Altium to create a footprint. Now change to your PCB Footprint library by double clicking the PCB library document on the project window and click Tools->IPC Footprint Wizard. This is shown in Figure 16. IPC Footprint Wizard is a tool in Altium which makes creating a Footprint much easier. It gives you options for package type and you enter in dimensions for the part, then it automatically generates the footprint. After selecting that a window will pop up like that in Figure 17.
Figure 17: IPC Footprint Wizard

Figure 18: IPC Footprint Wizard Component Selection

Figure 2.11
In Figure 18, you will have many choices for package type. We happen to choose a SOT-223 package for our LP3872 part. So select that component. If you have a different component, go through the list and try and find the package type that you part uses. If you can’t find it, try to find something that looks similar to it. After selecting the part, you will get a window like that of Figure 19. The numbers in Figure 19 have been filled out based on the data sheet. Now you try matching the sizes to the correct fields based on the data sheet and check your work.

**Figure 19: Footprint Dimensions**

If you refer to Figure 16, the package information on the data sheet, you can match up many of these dimensions in Figure 19 to that information. Go ahead and set the correct sizes. Click next and another window will pop up with more dimensions. This is shown in Figure 20. After entering in that information, there will be potentially more dimension information you need to enter. For our example, it will look like Figure 20.
After you have finished the specific dimension info windows, there will be a series of windows that ask about pad density and other info. Just keep clicking next and keep the default values. The pad density window is just describing how much extra room or metal do you want for each pin to connect to the board. If size or surface area is an issue, you should choose medium or high density. However, in your applications medium to low density is going to work fine or better because it is easier to solder. This window is seen in Figure 21.

Finally you will see a window that looks like Figure 22. This window shows what your footprint will be saved as in the library as well as its description. You can modify this to have more specific info if you wish. It might be useful to add the component it is to be intended to be used for in the part description.
The last window is where the footprint will be saved. Make sure your current library is selected and click next. This is shown in Figure 23.
After finishing the set of windows, a footprint will be generated on the screen in your PCB library that looks like Figure 24.
The different colors you see in Figure 24 represent the different layers on the PCB that different segments will be. For instance, the IPC footprint wizard generates a chip outline (yellow), component pads (red) and many other features automatically. A description of what each of the 6 basic layers can be seen in the table below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top Layer</td>
<td>Red</td>
<td>Top layer of copper (traces, pads, and pours)</td>
</tr>
<tr>
<td>Bottom Layer</td>
<td>Blue</td>
<td>Bottom layer of copper (traces, pads, and pours)</td>
</tr>
<tr>
<td>Top Overlay</td>
<td>Yellow</td>
<td>Top Silkscreen, where any writing or designators are visible after manufacturing.</td>
</tr>
<tr>
<td>Bottom Overlay</td>
<td>Brown</td>
<td>Bottom Silkscreen, where any writing or designators are visible after manufacturing.</td>
</tr>
<tr>
<td>Top Solder</td>
<td>Purple</td>
<td>Top Solder mask, the non-conductive polymer covering for the copper layer.</td>
</tr>
<tr>
<td>Bottom Solder</td>
<td>Pink</td>
<td>Bottom Solder mask, the non-conductive polymer covering for the copper layer.</td>
</tr>
</tbody>
</table>

**PCB Component Wizard**

Sometimes if IPC footprint wizard doesn’t have the exact chip model you are looking for, you can use the second design tool, Component Wizard. To do this, navigate to your PCB footprint library and click, **Tools->Component Wizard**. The window seen in Figure 25 will pop up.

![Figure 25: PCB Component Wizard](image)

Click next and you will see a list of various component package types to choose from. Here there are options to choose packages like Dual In-Line Package (DIP), or you can create custom surface mount
passive footprints like resistors, capacitors etc., and many other choices. This window is seen in Figure 26.

![Component Wizard Component Pattern](image)

**Figure 26: Component Wizard Component Pattern**

After you have selected whatever package you want to use, you will have footprint information to fill in just like we did in the IPC Footprint Wizard (section from above) from a specific component data sheet.

**Setting a Component’s Footprint**

The last important part to footprint design is to assign this footprint to a component in your schematic library. Save all your files and libraries, then change to your schematic library window. Change to the component you wish to add a footprint to by clicking **Tools->Goto->Next Component**. Go to the Component Properties menu and in that window click the drop down menu at the bottom called **Add Footprint**. A window will pop up as shown in Figure 27.
Select the browse button. A second window will pop up that looks like Figure 26. In the top drop-down menu, change libraries to your PCB footprint library and search for the component you just made. Finally, select the component you wish to match and press okay. Then, you will see a window like Figure 27. Press Okay, and now whenever you place that component in your project, it will have the associated Footprint!
Creating a Design

Adding Parts

For this example we will be making the schematic seen in Figure 25. Go ahead, as described before, and add all of the components that are needed for this small schematic. To rotate a component, press spacebar. When you have finished adding all of your components, or a set of them, you can use the automated method for enumerating the designator number. From the top toolbar click Tools->Annotate Schematics Quietly. The designators will auto-increment every component to a unique value in the entire schematic. Go ahead and add in all of the components you see in Figure 25 to your power module sheet. It should like the circuit in Error! Reference source not found..
After adding all of the passive components, we will need to change their footprints to whatever selection you have made. You do not have to do this with your custom component since it was already set during component creation. Typically, resistors, capacitors, diodes and other basic components can have the same size and footprint. Therefore we will set these resistors and capacitors to the generic 0805 standard (80 mils by 50 mils), 2012 metric (2 mm by 1.25 mm) standard footprint. This footprint already exists in the Altium’s libraries. To select this footprint for these components right click the component and click Properties. You should see a window with a bottom right corner that looks like the picture in Figure 31.
To add the new footprint click the add button as depicted in the previous figure. You should see the browse libraries window open up. Change the library to the Miscellaneous Devices library. In this library there is a capacitor 2012 and a resistor 2012. These are the same dimensions. So search through the list for the RESC2012M footprint. This is shown in Figure 32. You will notice there are three versions of the 2012 footprint (N,M,L). These represent the density of of the pad to component. You want low density meaning a large amount of extra pad area compared to where the component will overlay. This will make soldering easier. Select ok.

![Browse Libraries](image)

**Figure 32: Adding the 2012 Standard Footprint**

**Connecting Parts**

There are two physical implementations for connecting components together. The first is physically placing a wire between two connections. The second is creating a small wire on each component and labeling it with a Net. The net list is the preferred and the suggested implementation by circuit designers. It creates an easier way to debug connections throughout your design. It also allows you to more easily connect multiple pins to one another. An example of these can be seen in Figure 33.
To place a Net, click **Place->Net**. Then you must set the cursor over a wire and click. Once placed, you can double click the net to give it a unique name. For power and ground, there are pre made nets for you to use. On the top tool bar there are VCC and GND symbols that you can place. These two symbols are actually special Global nets that you can use that connect across all of the schematic sheets. You can change the name to be something else, but they just provide an easy way to label all of your VCC and GND nets. Nets are local to the sheet unless you add special off-sheet connector symbols or port symbols to make them connect across multiple sheets. All four of these symbols look like the pictures in Figure 34.

**Figure 34: Power, Ground, Port, and Off Sheet Symbols**

**Schematic Sheet Symbols**

Once you complete a diagram or small sub circuit within your larger design, you can represent that sub circuit in a higher level view of the project called a schematic sheet symbol. An example can be seen in Figure 37 which is based off of the circuit seen in Figure 30. This top level view can be used as a high level bock diagram of modules or systems within your complete project.

To create a schematic sheet symbol, you first must add a second empty schematic sheet to work as your top level sheet. Do this by clicking **Add new to project->Schematic**. Save this as something like Top_module.sch. Second, you need to add input/output ports to the pins you wish to connect to different schematic sheets. These are the flat yellow hexagons you see in Figure 30 and you can place them by clicking **place->port**. For our example do this for the VCC, Vin, and GND pins. Typically you do not create a port for power, but because this is a power module we did so we could represent the output power and ground rail. Then switch over to that sheet and right click the schematic sheet and select **Sheet Actions->Create Sheet Symbol From Sheet or HDL**. This can be seen in Figure 35.
A second window will then pop-up. It will ask you to choose what schematic sheet to create a symbol for. This window can be seen in Figure 36. Select the sheet you wish to use and press okay.
After you have added the sheet, a green box with labeled ports will show up on your top schematic sheet. Now all you have to do is connect the ports to the correct headers or other schematic sheet symbols if necessary. We will also add a Voltage rail LED for debugging purposes. Go ahead and change these components’ footprints to whatever you desire. The final schematic can be seen in Figure 37.
The Header P1 is an easy way to represent our power connector. In this case, we don't need to create our own component for the connector, but we do need to create the correct footprint for the 2 pin power connector.

Figure 37: Top Level Schematic with Sheet Symbol

The way you create symbols or modules and the amount of the schematic you wish to represent in each symbol is up to you. In our example we placed our power connector on the top level so that we could show the physical flow of inputs to outputs in the power module. You might put this all into one symbol.

This concludes the schematic portion of the Altium Schematic Directions tutorial.
Appendix

A.1 Repeated Schematic Symbol Design

There is a very fast and simple way to repeat layout and schematic designs in Altium if you have a schematic that involves many repeated symbols, like for motor design. The first objective is to create a schematic with as many generic repeatable parts in it as possible. Meaning, that if there are layout critical items, if bypass caps need certain proximity to the chip as well as other things. However, you want to leave out anything that might be unique to a single version of that schematic (for instance, an extra LED or extra components). In our example we will use a voltage regulator. A Board often needs multiple rails and therefore multiple regulators. Sometimes regulators require feedback resistors to set the output voltage. This is an example of a unique part for each schematic and should be included on the high level schematic. Below in Figure 38 you see that our voltage regulator schematic was used twice for a digital 3.3V rail and an analog 3.3V rail. There are also 2 Power rail LEDs that could have also been included in the sheet, but for this example we left them out.

Figure 38: Repeated Schematics

Next we will have to annotate the schematics quietly. However this is going to have a special effect on the components in the sheet. It will append the sheet name “3_3_V_Analog” to the end of each of the component names which will be too long for us. One way to fix this is to change the sheet name to something like S1, S2, S3, etc. The other way to this is to change the setting on how components in sheets are named. To do this, go to Project->Project Options. Click the Multi-Channel Tab on the top of this window. A window will appear like that seen in Figure 39.
If you click the pull down designate format list, you can select how you want the repeated rooms/sheets to name their components. I suggest selected `$Component$ChannelAlpha` or `$Component_$RoomName`. Select OK and return to your schematic. Now update your PCB with your newly changed schematics. You should see a something like that in Figure 40.
Here we have our generic voltage regulator circuit that we can layout. Instead of doing the layout for each of these separately, proceed with doing the layout for one of them. An example layout is seen in Figure 41.

After you finish the layout for the first, click Design->Rooms->Copy Room Formats. Then click inside the room format you want to copy, and second click inside the room you want it to copy to. Then a window will pop up that looks like that of Figure 42.
Figure 42: Copying Room Formats

Make sure you select whatever options you would like on the left panel and click OK. Then you will see the output on your PCB like that of Figure 43. How easy was that!!!

Figure 43: Copied Room Layout Format